安裝與pydantic問題

有任何提問的都來這
回覆文章
folkchen
文章: 1
註冊時間: 2021-09-27, 22:47

安裝與pydantic問題

文章 folkchen »

我開了一個 linux-mint 的 VM,安裝了 Anaconda3-2021.11-Linux-x86_64 建了一個 python 3.7.11 環境,接下來安裝 vnpy 2.9.0 完之後,要安裝 pip install shioaji 時出現了以下的錯誤
請問我接下來該如何處理?

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
hs-udata 0.3.4 requires requests>=2.23.0, but you have requests 2.22.0 which is incompatible.
fastapi 0.71.0 requires pydantic!=1.7,!=1.7.1,!=1.7.2,!=1.7.3,!=1.8,!=1.8.1,<2.0.0,>=1.6.2, but you have pydantic 1.0 which is incompatible.


另外,vnpy 的 shioaji gateway 要去哪邊取得?

或是這邊有沒有完整的安裝教學?
maxeii
系統管理員
文章: 24
註冊時間: 2021-09-01, 13:54

Re: 安裝與pydantic問題

文章 maxeii »

1. Shioaji 0.3.4.dev1 版本 Pydantic套件版本相依性升級了 你可以再試試看
2. 目前 Gateway 還沒改完,只有半成品。 https://github.com/Sinotrade/vnpy/tree/dev_sinopac
回覆文章